Webite speed
Incident Report for Agency Revolution - old one
Resolved
The issue has been resolved. Sorry for the delay, performance problems can be difficult to trace. In this case a component that was supposed to improve performance for a critical aspect of the web server - URL Management - actually had latent performance problems that didn't appear during testing. We are in a very stable position now.
Posted Jun 19, 2014 - 08:44 PDT
Monitoring
It appears we have the issue under control. We'll monitor it closely in the short-term.
Posted Jun 18, 2014 - 08:28 PDT
Identified
We're working on an issue related to website speed. It has our full attention and we'll update this very soon.
Posted Jun 18, 2014 - 08:15 PDT